Vulnerabilidad permite boquear o reiniciar dispositivos Nexus usando SMS

Publicado en Ciencia y Tecnología, Noticias,


Tweet about this on TwitterShare on Google+2Share on Facebook0Share on LinkedIn0

Los móviles de la gama Nexus son la apuesta de Google para ofrecer terminales de gama alta a precios más asequibles pero también son normalmente los terminales elegidos para estrenar nuevas versiones del sistema operativo Android. Hace unas semanas salía a la luz el Nexus 5 con la nueva versión de Android 4.4 bautizada como KitKat cosechando un gran éxito de ventas entre los usuarios por su ajustado precio y grandes prestaciones.

Precisamente por el éxito cosechado por estos terminales es cuanto menos preocupante la reciente publicación de una vulnerabilidad existente en todos los dispositivos Nexus. Según la información dada a conocer en el evento de seguridad DefCamp celebrado el pasado fin de semana, aprovechándose de esta vulnerabilidad, un atacante podría hacer que un terminal Nexus con cualquier versión de Android 4.x se reiniciase o se bloquease.

Fue en este evento donde el investigador Bogdan Alecu presentó la vulnerabilidad descubierta que permitiría a un atacante bloquear o reiniciar terminales Nexus de Google (Nexus, Nexus 4 y Nexus 5) mediante el envío de mensajes SMS conocidos como Class 0. Actualmente, todas las versiones de Android que se incluyen estos terminales se ven afectadas (4.2, 4.3 y 4.4).

¿Pero que es un mensaje Class 0 o Flash SMS? Estos mensajes son un tipo especial de SMS que no se almacena por defecto en el terminal que lo recibe y que es mostrado de manera inmediata al destinatario. Este tipo de mensajes suelen ser utilizados por las operadoras para enviar alertas o notificaciones y, tal y como demostró el investigador, al enviarse muchos de estos mensajes (alrededor de 30) en poco tiempo, el dispositivo puede llegar a reiniciarse, tal y como vemos en el siguiente vídeo:

No es el único efecto resultante del envío de estos mensajes puesto que en algunas ocasiones puede mostrarse el aviso de que la aplicación de mensajes se ha detenido o hacer que el sistema que permite la comunicación con la red móvil se reinicie, dejando al teléfono sin cobertura y forzando al usuario a realizar un reinicio de manera manual.

Sobre los dispositivos de otros fabricantes como Samsung o LG que también utilizan Android 4.x, este investigador no ha conseguido replicar este fallo por lo que el error parece estar en la manera en la que Google implementa estas características vulnerables en sus dispositivos Nexus.

El motivo de publicar esta vulnerabilidad parece ser el desinterés de Google en solucionarla, ya que este investigador asegura haber informado de este fallo a la empresa hace ya un año y que Google aseguró que la solucionaría cuando se publicase la versión 4.3 de Android (algo que no se ha cumplido, tal y como acabamos de ver).

Además de las evidentes molestias que esta vulnerabilidad pudiera causar a los usuarios de dispositivos Nexus, nuestros compañeros de Hispasec consideran que hay un escenario en el que podría ser aprovechado por un atacante. Este escenario es el de la seguridad bancaria ya que muchas entidades envían alertas SMS al realizar cierto tipo de operaciones y, si el dispositivo del usuario estuviese infectado por un malware que se aprovechase de esta vulnerabilidad este no recibiría aviso de posibles transacciones fraudulentas.

De momento y hasta que Google no publique un parche o nueva versión de Andorid que solucione esta vulnerabilidad la única manera existente de proteger nuestros dispositivos Nexus del envío malicioso de estos mensajes es utilizando alguna aplicación que filtre este tipo de mensajes. Un ejemplo de este tipo de utilidades es Class0Firewall desarrollada por Michael Mueller en colaboración con el descubridor de esta vulnerabilidad.


vía ESET

Califica esta entrada

Etiquetas: , ,


Deja un comentario

Cuanto es 7 + 19 ?
Please leave these two fields as-is:
IMPORTANTE! Necesitas resolver la operación matemática para poder continuar.

Newsletter

Redes sociales

Centro de soporte

Centro de recursos